Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Helix Cuff won’t turn on?

Hunter — Apr 22, 2018 11:10AM PDT

I got a Helix Cuff as a Christmas gift and love it, but lately I’ve had trouble charging and turning it on. When plugged it has a red light for a few minutes (maybe 10 mins) before disappearing (no white light, just turns off). Pressing and holding the main button won’t turn it on, and I’ve tried resetting as well but nothing has worked. Please help, these are my favorite earphones and I’d hate to toss them when theyre still so new!


1 Community Answers

Christina Reynolds - Apr 23, 2018 at 03:17PM PDT

Ashley Chloe C

Hi Hunter,

Thank you for writing in to give us an opportunity to help you!

If you do not see the Red status light or it goes out quickly after placing it into the charging case, please make sure the ear cushion is not pushed too far back on the ear tip, which could interfere with the charging process.

Please try adjusting and/or removing your earbud tip to check if the charging case will fully charge the earbud.

If these instructions do not work for you or if you have any additional questions or concerns, please email us at support@rowkin.com for further assistance.

Please note our customer support hours are Monday – Friday 9am – 6pm Pacific Time.

Thank you,

Christina

Rowkin Support Team
www.rowkin.com

rated : -1 Up Down

This question has received the maximum number of answers.